Как Google разбира, че ползвате стара версия на WordPress?

Може би сте забелязвали съобщение като това че уърдпреса ви трябва да се ъпдейтне. Ако се чудите как Google разбира, че версията на софтуера Ви, това става с така наречения мета генератор:
<meta name="generator" content="WordPress 2.9.2" />
Всъщност в конкретния случай Google грешки, защото сайтът vakantzia.info не е на WordPress, но за целите на някои експерименти има добавен въпросния генератор таг. Тоест, лесно можем да излъжем Google каква е системата ползвана за сайта.

8 мнения по „Как Google разбира, че ползвате стара версия на WordPress?

  1. Да, забелязал съм, че на WP-тата без този таг, независимо с колко по-стара версия са, не съм получил подобно съобщение. А чисто от Security гледна точка е добре хората да го разкарат тоя таг. Да не е особено ясно с какво е правен определен сайт, че по трудно да му се намерят дупките в сигурността.

  2. Евгени е прав. Когато излезе експлойт за определена версия на WP, този таг помага на автоматични паяци автоматично да откриват уязвими сайтове и дори в някои случай автоматично да ги атакуват. Иначе се съмнявам да скриеш от хакер, че сайта ти е на WP, особено ако ползва много разширения. Препоръчвам да скриете поне версията на софтуера.

  3. Подкрепям премахването на тага, макар понякога да няма особен смисъл. Ще се види я панела(и него скрийте и сменете default user-a), я друго и пак става ясно, но предполагам поне няма да е автоматично макар и там да може да се подобрят нещата }:>

    • Не, никакво значение от тази гледна точка 🙂
      Нарастнаха драстично обаче спам заявките към сървъра, опитващи се да публикуват коментари чрез софтуер 😉

Вашият коментар